Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is this a problem?
05-07-2014, 14:52
Post: #1
Is this a problem?
Out getting dirty today and noticed a treaded hole with no plug. Looks like its been out for a while?
8V92 just in front of oil drain
─░mage ─░mage

Gregg & Jane Gesse
1994 WLWB 40 Mid-Door
Find all posts by this user
Like Post Quote this message in a reply
05-07-2014, 19:28
Post: #2
RE: Is this a problem?
that's a new one on me

Ernie Ekberg
Prevost Liberty Classic XL
Weatherford, Tx
http://www.ernieekbergflooring.net
Find all posts by this user
Like Post Quote this message in a reply
05-07-2014, 20:33
Post: #3
RE: Is this a problem?
Is that on the bell housing? It's hard to tell in the pic but if so, that's the drain in case the input seal or crank seal leaks. It's threaded so you can route the drain somewhere else if you want.

TOM
Find all posts by this user
Like Post Quote this message in a reply
05-07-2014, 22:56
Post: #4
RE: Is this a problem?
(05-07-2014 20:33)oldmansax Wrote:  Is that on the bell housing? It's hard to tell in the pic but if so, that's the drain in case the input seal or crank seal leaks. It's threaded so you can route the drain somewhere else if you want.

TOM

Yes, I believe that is called the bell housing. So it's not a problem. Thank for help!
Gregg

Gregg & Jane Gesse
1994 WLWB 40 Mid-Door
Find all posts by this user
Like Post Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)